
WyrmNet V3.0.0 – Installation and Help 

1. Installation 

Installation is a simple process, just run the downloaded installation file (WyrmNetSetup.msi). 
All this does is put the WyrmNet application into the Program Files folder and creates a shortcut to it under 
'Wyrm Software' in your Programs menu. 

2. Setup 

There is nothing to setup. Once you've installed WyrmNet you can run it. 

2.1. Running for the first time 

When running for the first time, a box will appear asking if you want to use WyrmNet as your default telnet 
application. If you leave this selected then whenever a telnet link is clicked in your web browser you will 
automatically connect using WyrmNet. You can also select to never display this window again. Click 'OK' to 
continue. 

The first thing you will notice after running WyrmNet is that there is very little to it. Just a menu, a status bar, a 
tool bar, and a dialog bar. You can turn the last three of these off using the 'View' menu. 
The next thing to do is to make your first connection. You do this by clicking the 'File' menu and selecting the 
'New Connection' option. This will display the following window. 

 

In the 'Host Address' box you enter the full name of the machine you are trying to connect to (or its IP address); 
this also allows you to drop down a list of previously tried addresses. In the 'Port Type/Number' box you can 
either type in the port number of the service on the machine you are connecting to, or you can select one of the 
ports from the drop down list. Clicking the 'OK' button will attempt to create a connection window to the service 
on the machine. 
If all goes well, you should see a window appear inside WyrmNet that displays the welcome text from the 
service you are connecting to (which could be blank). You can now enter commands into the box at the bottom 
of this window. 

2.2. About the connection window 

When you have a connection window, a number of extra menu items appear (e.g. the 'Edit' and 'Window' 
menus). These menu items will be run through in the following sections. 
The connection window itself has two parts to it, a scrolling display area and a drop-down command box. The 
display area shows the responses (and optionally your commands) from the service you are connected to. You 
can copy this text simply by highlighting it with your mouse; once you release the mouse button the selected 



text is copied. The command box is where you type your commands, pressing the enter button to send the 
command to the service. You can also scroll back through the previous commands by using the drop down list 
associated with this command box or with the up and down arrow keys. 

2.3. The File Menu 

This menu has options which relate to connections. There is a 'New Connection' option which allows you to 
open another connection window (see section 2.1). The 'Open Connection' option opens a connection in the 
current connection window (closing any currently open connection). The 'Close Connection' option simply 
closes the current connection window. 
The 'Save Text' option allows you to save all the text currently held in the scrolling display window to a file. 
Under the 'Save Text' option is a list of recently successful connections, allowing you to open them again just by 
clicking on the relevant option. 
Lastly, there is the 'Exit' option which closes WyrmNet. 

2.4. The Edit Menu 

There are only two options on this menu. The 'Paste' option pastes text from the clipboard into the command 
box. If there are multiple lines then it sends all the lines, except the last, to the connected service automatically. 
This can also be done using the normal paste shortcuts. The 'Insert File' option allows you to select a text file to 
send to the service, sending each line in the file as a separate command including the last line. 

2.5. The Tools Menu 

This menu contains most of the extra features associated with MUCKs, MOOs, and MUDs. The 'Local Echo' 
option allows you to turn off (and on again) the appearance of your commands in the display window. The other 
options are detailed in the following sections. 

2.5.1. Logging Options 

The 'Log Text' option allows you to log all the display text to a file of your choosing. Once enabled, all text 
received is appended to that file. It does not save any previously received text. 
The 'Auto Log' option allows you to set up logging every time you connect to the current service. The option 
displays the following window. 

 



To set up auto logging, first click the 'Automatically log all text received' box to put a tick in it. You can then 
also, optionally, tick the 'Include any commands typed' if you also want to log the commands you type in 
amongst the text received from the connection. Next you select a directory (folder) in which to store the log 
files, the log files themselves are named automatically. Lastly you can select whether to create a log file each 
day (for busy connections), a log file each week (for slow connections), or a log file per connection. Clicking 
the 'OK' button will start the logging, and the next time you connect to this service the logging will 
automatically start. 

2.5.2. Options 

The 'Options' menu option allows you to change the display and command box attributes. It displays the 
following window (the text and background colours showing are those which the author had set at the time). 

 

The 'Back Colour' button allows you to select the background colour of the display area. The 'Text Colour' 
button allows you to select the text colour of the display area. The 'Display Font' button allows you to select a 
specific font for the text in the display area, it's recommended that you use the Fixedsys font for easy reading of 
character based systems. 
You can then change the amount of text that is held in the display area by changing the number in the 'Lines of 
text buffered in the display area' box. When new text is received it is placed at the bottom of the display area, 
and this continues until the number of lines reaches the predefined limit. Once the limit is reached then any lines 
coming in at the bottom will cause lines at the top to be removed. You should be careful when changing this 
setting as the larger the number the more memory is used. 
You can then change the number of previous commands that are stored in the drop down part of the command 
box. Just change the number in the 'Commands buffered in the drop-down list' box to suit. Again, larger values 
will cause more memory to be used. 
The 'Allow sending of Ctrl characters' box can be ticked if you want to be able to type characters such as Ctrl-M 
or Ctrl-G and have them sent straight through to the connection (the default is that they are filtered out). This is 
useful when connecting to telnet-based services. Clicking the 'OK' button will save all your changes 
immediately. 

2.5.3. Coloured Text 

Coloured Text provides a way of distinguising important lines of text from the rest of the messages, for example 
highlighting messages from a specific character. 
Clicking on the 'Coloured Text' menu option will display the following window. 



 

For a line to display in a different text colour, it has to match a keyword. To set a keyword, double click the 
blank scrolling area on the window (in this example it is green because the display area background colour is 
green and a keyword 'Red' has been entered). You will be shown a window very similar to the following. 

 

You can use this to specify whether the line to be highlighted should start with specific characters, or should just 
contain specific characters. You can then enter the keyword (case sensitive and any spaces or punctuation are 
included in the match) and press the 'OK' button to set it. 
Now, to set the colour of the highlight you need to right-click on the keyword and select the 'Set Colour' option. 
This will allow you to specify a specific colour. 
You can also add text, modify text, and delete text using the right-click menu. Finally, click the 'OK' button to 
save the keywords. 

2.5.4. Triggers  

These provide a way for you to be alerted when specific keywords are received. Selecting the 'Triggers' menu 
option will display the following window. 



 

In the text box below the 'Close' button, you can enter the keyword you want to trigger on (case insensitive but 
includes spaces and punctuation). Then you just click the '<< Add' button to add the keyword into the list. 
Optionally you can select a keyword in the list and click the 'Delete' button to remove it. 
At the bottom of the window you can select whether to just have an audible beep (you can select the type of 
beep from the drop down list, or browse for a WAV file to use instead), or just to flash the window, or both. All 
these changes are made immediately so clicking the 'Close' button just closes the window. 

2.5.5. Timed Text 

Timed text provides an automatic way to issue a command (or commands) on a regular basis. Clicking the 
'Timed Text' menu option displays the following window. 

 



Enter a command in the text box at the top left of the window, then click the '<< Add' button to add it to the list. 
You can optionally highlight a command in the list and click 'Remove' to remove it. WyrmNEt will send a 
command from the list at random each time it rund timed text. To determine how often a command is issued, 
change the number of seconds in the box below the 'Remove' button. Finally click the 'OK' button to save your 
changes. 

2.5.6. Shortcut Keys  

This allows you to set up the function keys to send commands. Clicking the 'Shortcut Keys' menu option will 
display the following window. 

 

To add a new shortcut key, click the 'Add' button. You will see the following window appear. 

 

Enter the function key number you want to set, then select whether it triggers when you just push that function 
key alone (normal), push it with one of the shift, control, or alt keys pressed at the same time. Then enter the 
command text you want to send and click the 'OK' button to save this shortcut. 

Back on the shortcut window, you can select an existing shortcut in the list by clicking on it, then click on the 
'Modify' button to alter the shortcut or the 'Delete' button to remove the shortcut. Clicking the 'OK' button will 
save your changes. 

2.5.7. Keypad Keys  



It is sometimes useful to have the keypad keys assigned commands, for example directional commands in 
MUCKs. Clicking on the 'Keypad keys' menu option displays the following window. 

 

These only trigger when Numlock is on. To set a key, simply click the key on the window then type in the text 
you want to send in the box on the right. Simple as that. Click the 'OK' key to save your changes. 

2.5.8. Aliases  

These are short text commands entered in the command box that cause longer text commands to be sent. 
Clicking on the 'Aliases' menu option displays the following window. 

 

The first thing you need to set is the initial character. This is the character that WyrmNet uses to determine if 
you've typed an alias or not. The default is \, but this can be changed to any in the drop-down list. When you 
type an alias you need to type this character first. 
You can highlight existing aliases in the list of aliases and click the 'Modify' button to alter them or the 'Delete' 
button to remove them. Clicking on the 'Add' button displays the following window. 



 

Here you enter the short command you want to use for the alias in the 'Alias' box, and then enter the command 
you want sent in the box below that. Multiple commands can be sent, one per line. 
In addition to that you can specify arguments to the alias within the commands. Whatever you type after the 
alias are called arguments, and are separated by spaces; so if you type '\hi Wyrm' then 'Wyrm' will be the first 
argument. You can include these arguments in the commands using $1, $2, $3 etc. $1 is replaced by the first 
argument, $2 by the second, etc. In the example the command 'say Hello $1' will replace the $1 with the first 
argument when the alias is typed; thus when '\hi Wyrm' is typed WyrmNet replaces the $1 with 'Wyrm' and 
sends 'say Hello Wyrm'. The character sequence $* is replaced by everything typed after the alias name. 

Clicking the 'OK' button on the aliases window saves your changes. 

2.5.9. Scripting 

Scripting provides automatic responses to received data. In other words, you can tell WyrmNet to do things 
depending on what it receives from the connected service. When you click the 'Scripting' menu option, the 
following window will appear (the 'OK' and 'Cancel' buttons change names unnervingly, but OK is always on 
the left). 



 

The list of scripts shows the condition and the commands in search order. When an event occurs (such as a timer 
or receiving a line of text) the script conditions are tested starting at the top of the list and working down; any 
conditions being met causing those commands to be sent. You can use the '^ Move Up' and 'v Move Down' 
buttons to change the order of a highlighted script. 
Highlighted scripts can also be altered by clicking the 'Modify' button and removed by clicking the 'Delete' 
button. 

To insert a script, you click either the 'Insert Before' or 'Insert After' buttons. If another script was highlighted 
then depending on the button clicked the new script would be inserted before or after the highlighted script. The 
insert buttons cause the following window to appear. 

 



The first thing you can select is the condition or trigger for the script. This is a choice between OnConnect (the 
script runs as soon as you connect to the service), OnReceive (the triggered scripts run each time WyrmNet 
receives a line of text), and OnTimer (the script runs periodically). If you select OnReceive then you enter a text 
trigger which, if it matches a received line of text, will cause the script to run. If you select OnTimer then you 
just need to enter a timer number, this being used in other scripts to start or stop the specific timer. 
Text triggers can contain wild cards (or they wouldn't be that useful). The character '*' is a wildcard match of 
anything, so the text trigger '*Wyrm*' would match any line with 'Wyrm' in it (including Wyrmling) but 
'Wyrm*' would only match those lines starting with 'Wyrm'. The '?' character matches any single character (and 
makes sure there has to be a character at that position), so '*Wyrm?' would match any line ending with 'Wyrm?' 
where '?' can be any single character (e.g. '...Wyrm.'). It can also use other regular expressions to match selected 
characters, e.g '[abc]' would match a single character which can be either 'a', 'b', or 'c', '[a-z]' would match a 
single character from 'a' to 'z', '[^n-z]' would match a single character that was not 'n' to 'z', '{word1|word2}' 
would match a word which was either 'word1' or 'word2', and '{^word1|word2}' would match a word that was 
not 'word1' or 'word2'. 

Below the condition is the commands list. You can highlight commands and modify or delete them (using the 
'Modify' and 'Delete' buttons respectively). Clicking on the 'Add' button brings up the following window and 
clicking on the 'OK' button saves your changes. 

 

Adding a script command requires you to first select the type of command from the drop down box (shown 
above in the dropped position). You can choose from beep (makes a noise when triggered), colour (changes the 
line's text colour when triggered), send (sends some text when triggered), setTimer (sets a timer running when 
triggered), killTimer (stops a timer running when triggered), line (sends one line at random from a file when 
triggered), read (sends a whole file when triggered), save (saves the current line to a file when triggered). 
The command selected determines what else you have to specify (e.g. for beep you have to select a system beep 
or browse for a WAV file). The various options include a sound (WAV) file, a specific colour reference, plain 
text, a timer number and delay (if setting the timer), or a file name. 
The text entered with the send command can contain special character sequences called 'arguments', which are 
replaced by words from the triggering text. Use '$*' to include all the triggering text in your message, or '$1' to 
'$9' to include one of the first 9 words in the triggering text. You can use '$$' to just show a '$' symbol. 
Clicking the 'OK' button saves the command to the 'Add Script' window. 

2.5.10. @image 

@image is really more a MUCK thing (named from the MUCK command), though it can be used for other 
things. This pops up a window containing a JPEG or GIF format image when it detects a specific trigger, or 
opens a link in a browser window when it detects an appropriate URL. Clicking on the '@image' menu item 
displays the following window. 



 

To enable it, click the 'Enable auto-URL checking' box. Then you can select whether to show GIF and JPEG 
images in a pop-up window when triggered, or to show a URL in the default browser when triggered. The 
typical GIF and JPEG trigger is '(@image)', this being the beginning of the response to the @image command 
(i.e. the response could be '(@image) http://www.wyrm.org.uk/pics/wyrm.jpg'). The recommended URL trigger 
is http:// which matches most URLs. In both cases, the URL is read up to the first space. 
When having a browser pop-up with a URL, you can put a tick in the 'Ask before displaying' box to have some 
control over what gets shown. When you click the 'OK' button, the settings become active. 

2.5.11. Copy From 

Clicking on the 'Copy From' menu item displays a window that allows you to copy all settings for the current 
connection from another previously made connection. This is useful if you always have the same settings 
throughout and don't want to set them up laboriously each time. Settings are only specific to the host name, so if 
you connect to the same host but on different ports then you coul dhave problems. 

2.5.12. Other Items 

When not connected to any services or hosts the Tools menu displays three items, 'Manage Settings', 'Export 
Settings', 'Import Settings'. The 'Manage Settings' item allows you to set and clear all the settings for the known 
hosts (which is useful if a script is causing problems on connection). 'Export Settings' will copy all settings for 
all known hosts to an export file, whereas 'Import Settings' will import that settings file into WyrmNet and 
override all other settings. 

2.6. The Window Menu 

This menu provides three methods for arranging the open windows within WyrmNet, 'Cascade', 'Tile', and 
'Arrange Icons'. You can also select any of the open windows from a list at the bottom of the menu, and that 
window will be brought to the front. 

2.7. The Help Menu 

The 'About WyrmNet' item is the only one that does anything. The 'Help Topics' menu item does nothing at 
present. 



3. Troubleshooting 

I tried to copy some text, but it's the wrong text! 
Sometimes the buffer seems to lose synchronisation with the display, but all you need to do to resynchronise the 
buffer is to change the window size. This causes all the lines to re-size themselves and fixes the buffer problem. 

4. Known Bugs/Features/Limitations 

@image problems 
Some links to images cause the @image code to crash. If you find such a link, please can you let me know so 
that I can fix the issue. 

 


